0
点赞
收藏
分享

微信扫一扫

hdu1213 How Many Tables (2016xynu暑期集训检测 -----A题)



How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25062    Accepted Submission(s): 12492


Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.



Input


The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

 

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.


Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4



Author

Ignatius.L

Source


​​杭电ACM省赛集训队选拔赛之热身赛​​



Recommend


Eddy



暑期集训结束了~


由于不是我出的题 也想做做。。。


一个并查集  用来检测集合的个数 

如果你看不懂  那么需要好好理解并查集了

并查集判环   并查集检测集合个数  等等 百度吧 少年

#include <stdio.h>
int fa[1005];
void init(int n)
{
for(int i=0;i<=n;i++)
fa[i]=i;
}
//查找根并压缩路径
int find(int x)
{
if(fa[x]!=x) fa[x]=find(fa[x]);
return fa[x];
}
int main()
{
int ncase;
scanf("%d",&ncase);
while(ncase--)
{
int n,m;
scanf("%d %d",&n,&m);
init(n);
for(int i=0;i<m;i++)
{
int a,b;
scanf("%d %d",&a,&b);
/*
判断 a,b 是否在同一个集合
如果在 不用合并
如果不在 合并集合
*/
int x=find(a);
int y=find(b);
if(x!=y)
fa[x]=y;
}
int cnt=0;
//查询集合的个数
for(int i=1;i<=n;i++)
{
if(fa[i]==i)
cnt++;
}
printf("%d\n",cnt);
}
return 0;
}


 




举报

相关推荐

0 条评论