0
点赞
收藏
分享

微信扫一扫

poj1363 Rails(栈模拟)



D - Rails


Crawling in process...

Crawling failed

Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u


Submit ​​Status​​​ ​​​Practice​​​ ​​​POJ 1363​​


System Crawler (2016-05-09)



Description



There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.



The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.




Input


The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0.


Output


The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.


Sample Input

51 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0


Sample Output


YesNo

Yes



读题读了好久。。。

大概题意就是问你 按照1.......n的顺序输入   能否输出你输入的那种序列

#include <stdio.h>
#include <stack>
using namespace std;
int main()
{
int n;
int num[1005];
while(~scanf("%d",&n)&&n)
{
while(true)
{
int x;
scanf("%d",&x);
if(x==0)
break;
else
{
num[0]=x;
for(int i=1;i<n;i++)
scanf("%d",&num[i]);
}
stack<int>s;
int t=0;
for(int i=0;i<n;i++)
{
s.push(i+1);
while(!s.empty()&&s.top()==num[t])
{
s.pop();
t++;
}
}
if(t==n)
puts("Yes");
else
puts("No");
while(!s.empty())
s.pop();
}
printf("\n");
}
return 0;
}



举报

相关推荐

0 条评论