0
点赞
收藏
分享

微信扫一扫

poj-2631-Road in the North【树的直径】



Roads in the North


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 2612

 

Accepted: 1291


Description


Building and maintaining roads among communities in the far North is an expensive business. With this in mind, the roads are build such that there is only one route from a village to a village that does not pass through some other village twice. 
Given is an area in the far North comprising a number of villages and roads among them such that any village can be reached by road from any other village. Your job is to find the road distance between the two most remote villages in the area. 

The area has up to 10,000 villages connected by road segments. The villages are numbered from 1. 


Input


Input to the problem is a sequence of lines, each containing three positive integers: the number of a village, the number of a different village, and the length of the road segment connecting the villages in kilometers. All road segments are two-way.


Output


You are to output a single integer: the road distance between the two most remote villages in the area.


Sample Input


5 1 6
1 4 5
6 3 9
2 6 8
6 1 7


Sample Output


22



此题想要输出程序运行结果,必须 敲回车+ ctrl z

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
const int Q=1e4+10;
struct node
{
int from,to,val,next;
}village[Q];
int head[Q];
int num;
void init()
{
memset(head,-1,sizeof(head));
num=0;
}
void addedge(int u,int v,int w)
{
village[num].from=u;
village[num].to=v;
village[num].val=w;
village[num].next=head[u];
head[u]=num++;
}
int ans,Tnode;
bool vis[Q];
int dist[Q];
void BFS(int x)
{
memset(vis,false,sizeof(vis));
memset(dist,0,sizeof(dist));
queue<int> qu;
qu.push(x);
vis[x]=true; ans=0;
while(!qu.empty())
{
int u=qu.front(); qu.pop();
for(int i=head[u];i!=-1;i=village[i].next)
{
int v=village[i].to;
if(!vis[v]&&dist[v]<dist[u]+village[i].val)
{
dist[v]=dist[u]+village[i].val;
if(ans<dist[v])
{
ans=dist[v];
Tnode=v;
}
vis[v]=true;
qu.push(v);
}
}
}
}
int main()
{
int a,b,c;
init();
while(scanf("%d %d %d",&a,&b,&c)!=EOF)
{
addedge(a,b,c);
addedge(b,a,c);
}
BFS(1); BFS(Tnode);
printf("%d\n",ans);
return 0;
}



举报

相关推荐

0 条评论