0
点赞
收藏
分享

微信扫一扫

hdu1045 Fire Net (dfs)


Fire Net


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11697    Accepted Submission(s): 7014


Problem Description


Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall. 


A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening. 



Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets. 



The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls through which bullets cannot run through. 



The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways. 


Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration. 


Input

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer n that is the size of the city; n will be at most 4. The next n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file. 

Output

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.


Sample Input

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


Sample Output

5
1
5
2
4


Source

​​Zhejiang University Local Contest 2001​​


Recommend

We have carefully selected several similar problems for you:   ​​1067​​​  ​​1258​​​  ​​1053​​​  ​​1789​​​  ​​1026​​ 


​​Statistic​​​ |  ​​Submit​​​ |  ​​Discuss​​​ |  ​​Note​​


由于这道题的n最大才为4  所以可以深搜。其实我的第一印象是二分匹配的  

没办法 喜欢搜索

#include <stdio.h>
#include <string.h>
int n,sum;
char map[10][10];
bool vis[10][10];
//边界检测
bool limit(int x,int y)
{
if(x<0||y<0||x>=n||y>=n) return false;
return true;
}
//检测
bool check(int x,int y)
{
//检查第x行
for(int i=y-1;i>=0;i--)
{
if(vis[x][i]) return false;
if(map[x][i]=='X') break;
}
for(int i=y+1;i<n;i++)
{
if(vis[x][i]) return false;
if(map[x][i]=='X') break;
}
//检查第y列
for(int i=x-1;i>=0;i--)
if(vis[i][y]||map[i][y]=='X')
{
if(vis[i][y]) return false;
if(map[i][y]=='X') break;
}
for(int i=x+1;i<n;i++)
{
if(vis[i][y]) return false;
if(map[i][y]=='X') break;
}
return true;
}
void dfs(int flag,int count)
{
int x=flag/n,y=flag%n;

// printf("-%d- ",count);
if(count>sum) sum=count;
if(!limit(x,y)) return ;

if(map[x][y]!='X'&&!vis[x][y]&&check(x,y))
{
vis[x][y]=true;
// printf("%d %d \n",x,y);
dfs(flag+1,count+1);
// printf("\n*******************************\n");
vis[x][y]=false;
}
dfs(flag+1,count);
}
int main()
{
//freopen("in.txt","r",stdin);
while(~scanf("%d",&n)&&n)
{
memset(vis,false,sizeof(vis));
memset(map,0,sizeof(map));
for(int i=0;i<n;i++)
scanf("%s",map[i]);
sum=0;
dfs(0,0);
printf("%d\n",sum);
}
return 0;
}




举报

相关推荐

0 条评论