0
点赞
收藏
分享

微信扫一扫

POJ 2492 A Bug's Life(并查集)

Just_Esme 2023-02-03 阅读 72


Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2 3 3 1 2 2 3 1 3 4 2 1 2 3 4

Sample Output

Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!

Hint

Huge input,scanf is recommended.

给出T组数据,每组数据表示有n只虫和m对关系,接下来m行输入(x,y),表示x和y是相爱的异性,若这m对关系中出现了错误,即后给出的关系与之前的关系互相冲突(同性相爱),则输出  Suspicious bugs found! 否则输出  No suspicious bugs found! 
例:
3 3 //三个虫子,三对关系
1 3 //1和3是异性
2 3 //2和3是异性(此时可发现1和2是同性) 
1 2 //这时再说出1和2是异性和前面的关系出现冲突,要输出 Suspicious bugs found!
这道题我没读懂题意,想明白以后就是不能在相同的集合中再次添加相同的点,就是并查集的简单应用。

AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<string>
#include<cstring>
#include<cmath>
#include<ctime>
#include<algorithm>
#include<utility>
#include<stack>
#include<queue>
#include<vector>
#include<set>
#include<map>
using namespace std;
int flag,T,n,fa[4005],m;
void init()
{
for (int i=0; i<=2*n+1; i++)
fa[i]=i;
}
int Find(int x)
{
if (fa[x]==x)
return x;
return fa[x]=Find(fa[x]);
}
void unio(int x,int y)
{
fa[Find(x)]=Find(y);
return ;
}
int main()
{
scanf("%d",&T);
for (int t=1; t<=T; t++)
{
scanf("%d%d",&n,&m);
init();
flag=0;
for(int i=1; i<=m; i++)
{
int x,y;
scanf("%d %d",&x,&y);
if(flag)
continue;
if(Find(x)==Find(y))
{
flag=1;
continue ;
}
unio(x+n,y);
unio(x,y+n);
}
printf("Scenario #%d:\n",t);
if(flag)
printf("Suspicious bugs found!\n");
else
printf("No suspicious bugs found!\n");
printf("\n");
}
return 0;
}

 

举报

相关推荐

0 条评论