0
点赞
收藏
分享

微信扫一扫

zoj 1094 poj 2246 Matrix Chain Multiplication(堆栈)

数数扁桃 2023-03-22 阅读 39


Matrix Chain Multiplication


Time Limit: 1000MS

 

Memory Limit: 65536K

Total Submissions: 1695

 

Accepted: 1090


Description


Suppose you have to evaluate an expression like A*B*C*D*E where A,B,C,D and E are matrices.
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary. However, the number of elementary multiplications needed strongly depends on the evaluation order you choose.
For example, let A be a 50*10 matrix, B a 10*20 matrix and C a 20*5 matrix.
There are two different strategies to compute A*B*C, namely (A*B)*C and A*(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.

Your job is to write a program that determines the number of elementary multiplications needed for a given evaluation strategy.


Input


Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 <= n <= 26), representing the number of matrices in the first part. The next n lines each contain one capital letter, specifying the name of the matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):

SecondPart = Line { Line } 

Line = Expression

Expression = Matrix | "(" Expression Expression ")"

Matrix = "A" | "B" | "C" | ... | "X" | "Y" | "Z"


Output


For each expression found in the second part of the input file, print one line containing the word "error" if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one line containing the number of elementary multiplications needed to evaluate the expression in the way specified by the parentheses.


Sample Input


9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))


Sample Output


0
0
0
error
10000
error
3500
15000
40500
47500
15125


Source

​​Ulm Local 1996​​

 

 

Source Code

Problem: 2246 User: nealgavin
Memory: 252K Time: 0MS
Language: C++ Result: Accepted

Source Code
#include<iostream>
#include<cstring>
#include<stack>
#include<map>
using namespace std;
class node
{
public:int row,col;
};
map<char,node>matri;
stack<node>array;
int main()
{
int n;
char name;
cin>>n;
for(int i=0;i<n;i++)
{
cin>>name;cin>>matri[name].row>>matri[name].col;
}
char css[123];
while(cin>>css)
{ int len=strlen(css);
int count=0;bool flag=0;
for(int i=0;i<len;i++)
{
if(css[i]=='(')continue;
else if(css[i]==')')
{
node a=array.top();array.pop();
node b=array.top();array.pop();
if(b.col!=a.row){flag=1;cout<<"error\n";break;}
else {count+=b.row*b.col*a.col;b.col=a.col;array.push(b);}
}
else array.push(matri[css[i]]);
}
if(!flag)
cout<<count<<"\n";
}
}

 

 

举报

相关推荐

0 条评论