0
点赞
收藏
分享

微信扫一扫

集训队专题(3)1002 Free DIY Tour

心如止水_c736 2022-08-30 阅读 183


Free DIY Tour

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5544    Accepted Submission(s): 1776


Problem Description

Weiwei is a software engineer of ShiningSoft. He has just excellently fulfilled a software project with his fellow workers. His boss is so satisfied with their job that he decide to provide them a free tour around the world. It's a good chance to relax themselves. To most of them, it's the first time to go abroad so they decide to make a collective tour.

The tour company shows them a new kind of tour circuit - DIY circuit. Each circuit contains some cities which can be selected by tourists themselves. According to the company's statistic, each city has its own interesting point. For instance, Paris has its interesting point of 90, New York has its interesting point of 70, ect. Not any two cities in the world have straight flight so the tour company provide a map to tell its tourists whether they can got a straight flight between any two cities on the map. In order to fly back, the company has made it impossible to make a circle-flight on the half way, using the cities on the map. That is, they marked each city on the map with one number, a city with higher number has no straight flight to a city with lower number. 

Note: Weiwei always starts from Hangzhou(in this problem, we assume Hangzhou is always the first city and also the last city, so we mark Hangzhou both  1 and N+1), and its interesting point is always 0.

Now as the leader of the team, Weiwei wants to make a tour as interesting as possible. If you were Weiwei, how did you DIY it?

 


Input

The input will contain several cases. The first line is an integer T which suggests the number of cases. Then T cases follows.
Each case will begin with an integer N(2 ≤ N ≤ 100) which is the number of cities on the map.
Then N integers follows, representing the interesting point list of the cities.
And then it is an integer M followed by M pairs of integers [Ai, Bi] (1 ≤ i ≤ M). Each pair of [Ai, Bi] indicates that a straight flight is available from City Ai to City Bi.

 


Output

For each case, your task is to output the maximal summation of interesting points Weiwei and his fellow workers can get through optimal DIYing and the optimal circuit. The format is as the sample. You may assume that there is only one optimal circuit. 

Output a blank line between two cases.

 


Sample Input

2
3
0 70 90
4
1 2
1 3
2 4
3 4
3
0 90 70
4
1 2
1 3
2 4
3 4

 

Sample Output

CASE 1#
points : 90
circuit : 1->3->1

CASE 2#
points : 90
circuit : 1->2->1


Author

JGShining(极光炫影)

 


Source

​​杭州电子科技大学第三届程序设计大赛​​

 

        此题说是最短(长)路径题,不如说是动态规划+路径判断。

题意:给你一个有环的图,结点之间有路径,每个结点都有个兴趣值,现在给你起点,找一条路径再次回到起点,使经过的结点的兴趣值总和最大,问最大的总和是多少并且输出其路径。

      只从题意的角度讲,很像动态规划里面的最长公子序列(小编我就是这样做的……),此题的数据也不是很强,所以我们还是采取Floyd算法吧


#include <cstdio>
#include <cstring>
#define maxn 1010
int map[maxn][maxn],v[maxn],pre[maxn],dp[maxn];
void out(int i)
{
if(i == 1)
{
printf("1");
return;
}
out(pre[i]);
printf("->%d",i);
}
int main()
{
int t,c=0;
scanf("%d",&t);
while(t--)
{
int n,i,j,m,end;
memset(v,0,sizeof(v));
memset(pre,0,sizeof(pre));
memset(map,0,sizeof(map));
memset(dp,0,sizeof(dp));
scanf("%d",&n);
for(i=1; i<=n; i++)
scanf("%d",&v[i]);
scanf("%d",&m);
while(m--)
{
int a,b;
scanf("%d%d",&a,&b);
map[a][b] = 1;
}
for(i=1; i<=n+1; i++)
{
for(j=1; j<i; j++)
{
if(map[j][i] && dp[i]<dp[j]+v[i])
{
dp[i] = dp[j]+v[i];
pre[i] = j;
}
}
}
printf("CASE %d#\n",++c);
printf("points : %d\n",dp[n+1]);
printf("circuit : ");
out(pre[n+1]);
printf("->1\n");
if(t) printf("\n");
}
return 0;
}



举报

相关推荐

0 条评论