0
点赞
收藏
分享

微信扫一扫

POJ 2503 Babelfish(hash + map)

书呆鱼 2022-11-18 阅读 71


Babelfish


Time Limit: 3000MS

 

Memory Limit: 65536K

Total Submissions: 41466

 

Accepted: 17610


Description


You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.


Input


Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.


Output


Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".


Sample Input


dog ogday cat atcay pig igpay froot ootfray loops oopslay atcay ittenkay oopslay


Sample Output

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <map>
using namespace std;

int main()
{
map<string, string>word;
char a[50],L[20],S[20],M[20];
int i;
while(gets(a)&&a[0]!='\0')
{
sscanf(a,"%s%s",&S,&L);
word[L]=S;
}
while(cin>>M)
{
if(word.find(M)!=word.end())
{
cout<<word[M]<<endl;
}
else
{
cout<<"eh"<<endl;
}
}
return 0;
}

举报

相关推荐

0 条评论