0
点赞
收藏
分享

微信扫一扫

Highways



Problem Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.


Input

The first line of input is an integer T, which tells how many test cases followed. <br>The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.


Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input


1

3
0 990 692
990 0 179
692 179 0


Sample Output

692


题目大概:

几个村子修路,问最少的修路的长度。

思路:

有关并查集的算法,我用的kruskal。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;


int m,r,sum=0,k=0;
int map[505][525];
int father[505];
int vi[502][502];
struct point
{
int x,y,v;
}a[505];

int cmp(const point &a,const point &b)
{
if(a.v<b.v)return 1;
else return 0;
}


int fa(int a)
{
if(father[a]!=a)father[a]=fa(father[a]);
return father[a];
}

int unite(int q,int w)
{int faa,fbb;
faa=fa(q);
fbb=fa(w);
if(faa!=fbb)father[faa]=fbb;

return 0;
}


int main()
{
int t;
cin>>t;
for(int p=1;p<=t;p++)
{
memset(map,0,sizeof(map));
memset(father,0,sizeof(father));
memset(vi,0,sizeof(vi));
sum=0;
int n;
cin>>n;
r=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{
cin>>map[i][j];
if(map[i][j]!=0&&!vi[j][i])
{ vi[i][j]=1;
r++;

a[r].x=i;a[r].y=j;a[r].v=map[i][j];

}

}
}
for(int i=1;i<=n;i++)father[i]=i;
sort(a+1,a+r+1,cmp);
k=0;
for(int i=1;i<=r;i++)
{
if(fa(a[i].x)!=fa(a[i].y))
{
unite(a[i].x,a[i].y);
sum+=a[i].v;
k++;

}
if(k==n-1)break;
}
cout<<sum<<endl;
if(t!=p)cout<<endl;


}
return 0;
}





举报

相关推荐

0 条评论