0
点赞
收藏
分享

微信扫一扫

uva 10795 - A Different Task(递推,3级)

胡桑_b06e 2023-05-19 阅读 18


 A Different Task




The (Three peg) Tower of Hanoi problem is a popular one in computer science. Briefly the problem is to transfer all the disks from peg-A to peg-C using peg-B as intermediate one in such a way that at no stage a larger disk is above a smaller disk. Normally, we want the minimum number of moves required for this task. The problem is used as an ideal example for learning recursion. It is so well studied that one can find the sequence of moves for smaller number of disks such as 3 or 4. A trivial computer program can find the case of large number of disks also.

Here we have made your task little bit difficult by making the problem more flexible. Here the disks can be in any peg initially.




If more than one disk is in a certain peg, then they will be in a valid arrangement (larger disk will not be on smaller ones). We will give you two such arrangements of disks. You will have to find out the minimum number of moves, which will transform the first arrangement into the second one. Of course you always have to maintain the constraint that smaller disks must be upon the larger ones.

Input

The input file contains at most 100 test cases. Each test case starts with a positive integer N ( 1N60), which means the number of disks. You will be given the arrangements in next two lines. Each arrangement will be represented by N integers, which are 12 or 3. If the i-th ( 1iN) integer is 1, you should consider that i-th disk is on Peg-A. Input is terminated by N = 0. This case should not be processed.

Output

Output of each test case should consist of a line starting with `Case #: ' where #

Sample Input


31 1 12 2 2
3
1 2 3
3 2 1
4
1 1 1 1
1 1 1 1
0


Sample Output


Case 1: 7Case 2: 3Case 3: 0



Problem setter: Md. Kamruzzaman

Special Thanks: Derek Kisman (Alternate Solution), Shahriar Manzoor (Picture Drawing)

Miguel Revilla 2004-12-10


思路:汉诺塔可逆,所以A->B+C->B等价于A->C 如果过程中肯定需要B的话。

           F(f,num,where) f是状态序列,num为第几个,where 为 状态序列中第num个应该在哪。

           如果f[num]==where   F(f,num,where)等价于 F(f,num-1,where)

           否则就将其搬到合适状态。需要2^(num-1) 汉诺塔结论

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int mm=64;
int f[mm],t[mm];
long long go(int*f,int num,int where)
{
  if(num<=0)return 0;///已经完毕
  if(f[num]==where)return go(f,num-1,where);///相同,不动,继续考察上一块
  return go(f,num-1,6-where-f[num])+(1LL<<(num-1));///2^num-1,移一次的代价
}
int main()
{ int n;int cas=0;
  while(scanf("%d",&n)&&n)
  {
    for(int i=1;i<=n;++i)scanf("%d",&f[i]);
    for(int i=1;i<=n;++i)scanf("%d",&t[i]);
    int num=n;
    while(f[num]==t[num]&&num>=1)--num;///符合条件的最大块不动
    long long ans=0;
    if(num<1)goto out;
    ///因为搬动可逆,所以A->B +C->B == A->C 步骤数
    ///将前num-1块移走,然后调整最大块
        ans=go(f,num-1,6-f[num]-t[num])+go(t,num-1,6-t[num]-f[num])+1L;
  out:  printf("Case %d: %lld\n",++cas,ans);
  }
}


             

 


举报

相关推荐

0 条评论