0
点赞
收藏
分享

微信扫一扫

HDOJ--2163 Palindromes

SPEIKE 2022-08-16 阅读 28


Palindromes


Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4122    Accepted Submission(s): 2405


Problem Description


Write a program to determine whether a word is a palindrome. A palindrome is a sequence of characters that is identical to the string when the characters are placed in reverse order. For example, the following strings are palindromes: “ABCCBA”, “A”, and “AMA”. The following strings are not palindromes: “HELLO”, “ABAB” and “PPA”.



Input


The input file will consist of up to 100 lines, where each line contains at least 1 and at most 52 characters. Your program should stop processing the input when the input string equals “STOP”. You may assume that input file consists of exclusively uppercase letters; no lowercase letters, punctuation marks, digits, or whitespace will be included within each word.



Output


A single line of output should be generated for each string. The line should include “#”, followed by the problem number, followed by a colon and a space, followed by the string “YES” or “NO”.



Sample Input

ABCCBA
A
HELLO
ABAB
AMA
ABAB
PPA
STOP


 


Sample Output

#1: YES
#2: YES
#3: NO
#4: NO
#5: YES
#6: NO
#7: NO



import java.util.Scanner;

class Main {

public static void main(String[] args) {
Scanner sc=new Scanner(System.in);
int t=1;
while(sc.hasNext()){
String str=sc.next();
boolean isFirst=true;
if("STOP".equals(str)){
return;
}
System.out.print("#"+(t++)+": ");
for(int i=0,j=str.length()-1;i<j;i++,j--){
if(str.charAt(i)!=str.charAt(j)){
isFirst=false;
break;
}
}
if(isFirst){
System.out.println("YES");
}else{
System.out.println("NO");
}
}
}
}




 

举报

相关推荐

0 条评论