0
点赞
收藏
分享

微信扫一扫

Agri-Net



Problem Description


Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.
Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.
Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.
The distance between any two farms will not exceed 100,000.


Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.


Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0


Sample Output

28

题目大概:

多个农场按光缆,问最短按多少,所有农场连起来。

思路:

并查集,有关的算法。我用的kruskal。

代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
using namespace std;


long long m,r,sum=0,k=0;

int father[10002];

struct point
{
int x,y,v;
}a[10002];

int cmp(const point &a,const point &b)
{
if(a.v<b.v)return 1;
else return 0;
}


int fa(int a)
{
if(father[a]!=a)father[a]=fa(father[a]);
return father[a];
}

int unite(int q,int w)
{int faa,fbb;
faa=fa(q);
fbb=fa(w);
if(faa!=fbb)father[faa]=fbb;

return 0;
}


int main()
{
int n;
while(cin>>n)
{
memset(father,0,sizeof(father));
r=0;
for(int i=1;i<=n;i++)
{
for(int j=1;j<=n;j++)
{ int g;
cin>>g;
if(g!=0)
{
r++;

a[r].x=i;a[r].y=j;a[r].v=g;

}

}
}
for(int i=1;i<=n;i++)father[i]=i;
sort(a+1,a+r+1,cmp);
k=0;
sum=0;
for(int i=1;i<=r;i++)
{
if(fa(a[i].x)!=fa(a[i].y))
{
unite(a[i].x,a[i].y);
sum+=a[i].v;
k++;
if(k==n-1)break;
}

}
cout<<sum<<endl;

}
return 0;
}




举报

相关推荐

0 条评论