0
点赞
收藏
分享

微信扫一扫

PAT 1086 Tree Traversals Again(中,前,后)

斗米 2023-03-02 阅读 17


1086 Tree Traversals Again (25分)

An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.

PAT 1086 Tree Traversals Again(中,前,后)_前序


Figure 1

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.

Output Specification:

For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop

Sample Output:

3 4 2 6 5 1

题意:根据中序前序,求出后序。

这道题能看懂样例,就很容易写出来,关键点是所有的入栈Push元素顺序构成的序列为树的前序遍历序列所有的出栈Pop元素顺序构成的序列为中序遍历序列。

//根据 中序 前序  找 后序 
#include <bits/stdc++.h>
using namespace std;
vector<int> pre, in, post;
int n, num;
string opt;
//rt是前序当前根节点的下标
//st,en 分别是当前子树在中序序列最左端和最右端的下标
void postOrder(int rt, int st, int en){
if(st > en) return ;
int i = st;
while(i < en && in[i] != pre[rt]) i++;
postOrder(rt + 1, st, i - 1);
postOrder(rt + 1 + i - st, i + 1, en);
post.push_back(pre[rt]);
}
int main(){
stack<int> s;
while(!s.empty()) s.pop();
cin >> n;
for(int i = 0; i < 2*n; i++){
cin >> opt;
if(opt == "Push"){ //前序
cin >> num;
s.push(num);
pre.push_back(num);
}else{ //中序
in.push_back(s.top());
s.pop();
}
}
postOrder(0, 0, n-1);
for(int i = 0; i < n; i++){
cout << post[i] ;
if( i != n-1) cout << " ";
}
cout << endl;
return 0;
}

 

举报

相关推荐

0 条评论