0
点赞
收藏
分享

微信扫一扫

hdu1058 Humble Numbers--DP


原题链接: ​​ http://acm.hdu.edu.cn/showproblem.php?pid=1058​​


一:原题内容


Problem Description


A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence


 


Input


The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.


 


Output


For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.


 


Sample Input


1 2 3 4 11 12 13 21 22 23 100 1000 5842 0


 


Sample Output


The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.


 


二:分析理解

整体思想是利用已经知道的序列中的元素根据规则去生成新的元素, 如x * 2, x * 3, x * 5, x * 7.
假设使用数组a[MAX]进行存储这一序列的所有元素, 首先使a[0] = 1, 表示第一个元素是1, 然后利用4个指针(不是内存指针,呵呵), i2 = i3 = i5 = i7 = 0. 每次我们比较 a[i2] * 2, a[i3] * 3, a[i5] * 5, a[i7] * 7 这四个元素的大小, 把最小的放到序列中, 并把对应的指针+1, 直到生成需要的个数.


三:AC代码

#include<iostream>  
#include<string.h>
#include<algorithm>

using namespace std;

int a[6000];

int main()
{
a[1] = 1;
int i2, i3, i5, i7;
i2 = i3 = i5 = i7 = 1;

for (int i = 2; i <= 5842; i++)
{
int x = min(min(a[i2] * 2, a[i3] * 3), min(a[i5] * 5, a[i7] * 7));

if (x == a[i2] * 2) i2++;//这个地方不能用if...else语句,因为四个数的比较可能存在相等的
if (x == a[i3] * 3) i3++;
if (x == a[i5] * 5) i5++;
if (x == a[i7] * 7) i7++;

a[i] = x;
}

int n;

while (scanf("%d", &n) && n)
{
if (n % 10 == 1 && n % 100 != 11)
printf("The %dst humble number is ", n);
else if (n % 10 == 2 && n % 100 != 12)
printf("The %dnd humble number is ", n);
else if (n % 10 == 3 && n % 100 != 13)
printf("The %drd humble number is ", n);
else
printf("The %dth humble number is ", n);

printf("%d.\n", a[n]);

}

return 0;
}



举报

相关推荐

0 条评论