0
点赞
收藏
分享

微信扫一扫

POJ 1276(多重背包+二进制优化)


Cash Machine

Time Limit: 1000MS Memory Limit: 10000K

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:

@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 … nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.

Sample Input

735 3 4 125 6 5 3 350
633 4 500 30 6 100 1 5 0 1
735 0
0 3 10 100 10 50 10 10

Sample Output

735
630
0
0

Hint

The first data set designates a transaction where the amount of cash requested is @735. The machine contains 3 bill denominations: 4 bills of @125, 6 bills of @5, and 3 bills of @350. The machine can deliver the exact amount of requested cash.

In the second case the bill supply of the machine does not fit the exact amount of cash requested. The maximum cash that can be delivered is @630. Notice that there can be several possibilities to combine the bills in the machine for matching the delivered cash.

In the third case the machine is empty and no cash is delivered. In the fourth case the amount of cash requested is @0 and, therefore, the machine delivers no cash.

问题分析

就是给出背包容量,和物品数量与价值,问可获得的最大价值。
普通枚举会tle,所以需要二进制优化一下,因为其中普通枚举的一段肯定是会有连续的,这一段我们可以通过二进制来重新分配成一个物品,最后01背包模板就行了,和hdu 2844一样的….详情参见​​HDU 2844 coins​​

#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
typedef long long ll;
const int N = 1e3;

struct money
{
int v,k;
}a[N];
int dp[N*100+1],tmp[N*100+1];

int solve(int n)//核心,二进制重新分配价值
{
int k = 0;
for(int i = 0; i < n; ++i)
{
for(int j = 1; j <= a[i].k; j<<=1)
{
tmp[k++] = j*a[i].v;
a[i].k -= j;
}
if(a[i].k>0)
tmp[k++] = a[i].k * a[i].v;
}
return k;
}

void zeroOne(int n,int sum)//01背包模板
{
int k = solve(n);
for(int i = 0; i < k; ++i)
{
for(int j = sum; j >= tmp[i]; --j)
dp[j] = max(dp[j],dp[j-tmp[i]]+tmp[i]);
}
}

int main()
{
// freopen("in.txt","r",stdin);
int sum,n;
while (~scanf("%d%d",&sum,&n))
{
memset(tmp,0, sizeof(tmp));
memset(a,0, sizeof(a));
memset(dp,0, sizeof(dp));
for(int i = 0; i < n; ++i)
{
scanf("%d%d",&a[i].k,&a[i].v);
}
zeroOne(n,sum);
printf("%d\n",dp[sum]);
}
return 0;
}


举报

相关推荐

0 条评论