0
点赞
收藏
分享

微信扫一扫

集训队专题(1)1008 Repository


Repository

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/65536K (Java/Other)
Total Submission(s) : 88   Accepted Submission(s) : 18


Problem Description


When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.


 



Input


There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.


 



Output


For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.


 



Sample Input


20

ad

ae

af

ag

ah

ai

aj

ak

al

ads

add

ade

adf

adg

adh

adi

adj

adk

adl

aes

5

b

a

d

ad

s


 



Sample Output


0

20

11

11

2


 



Source


2009 Multi-University Training Contest 4 - Host by HDU


 


此题和之前的那道“统计难题”很像,所以这里我们仍然采用数组模拟的方法来解决这道题,如果之前“统计难题”看懂了做出来了,那这道题对于我们来说,就是略微加强一点的水题啦(小编~)。

#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <iostream>
using namespace std;
struct node
{
int id;
int cnt;
int al[26];
};
int ptr=0;
node word[1000000];
void Init(int z)
{
for(int i=0;i<26;i++)
word[z].al[i]=-1;
}
void Insert(char*s,int len,int x)
{
int now=0;
for(int i=0;i<len;i++)
{
if(word[now].al[s[i]-'a']==-1)
{
word[now].al[s[i]-'a']=++ptr;
Init(ptr);
now=ptr;
}
else now=word[now].al[s[i]-'a'];
if(word[now].id!=x) word[now].cnt++;
word[now].id=x;
}
}
int find(char*s)
{
int now=0;
int len=strlen(s);
for(int i=0;i<len;i++)
{
if(word[now].al[s[i]-'a']==-1)
return 0;
now=word[now].al[s[i]-'a'];
}
return word[now].cnt;
}
int main()
{
int n,m,len;
char s[21];
Init(0);
scanf("%d",&n);
while(n--)
{
scanf("%s",&s);
len=strlen(s);
for(int i=0;i<len;i++)
Insert(s+i,len-i,n+1);
}
scanf("%d",&m);
while(m--)
{
scanf("%s",&s);
printf("%d\n",find(s));
}
return 0;
}



举报

相关推荐

0 条评论