0
点赞
收藏
分享

微信扫一扫

poj 2769 Reduced ID Numbers

狐沐说 2022-12-07 阅读 15


Description
T. Chur teaches various groups of students at university U. Every U-student has a unique Student Identification Number (SIN). A SIN s is an integer in the range 0 ≤ s ≤ MaxSIN with MaxSIN = 106-1. T. Chur finds this range of SINs too large for identification within her groups. For each group, she wants to find the smallest positive integer m, such that within the group all SINs reduced modulo m are unique.

Input
On the first line of the input is a single positive integer N, telling the number of test cases (groups) to follow. Each case starts with one line containing the integer G (1 ≤ G ≤ 300): the number of students in the group. The following G lines each contain one SIN. The SINs within a group are distinct, though not necessarily sorted.

Output
For each test case, output one line containing the smallest modulus m, such that all SINs reduced modulo m are distinct.

Sample Input

2
1
124866
3
124866
111111
987651

Sample Output

1
8

#include<cstdio>
#include<cstring>
#define N 1000001
int a[N],mark[100001];
int main(){
int t,n,i,j,find;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i]);
for(i=1;;i++){
memset(mark,0,sizeof(mark));
for(find=1,j=1;j<=n;j++){
if(mark[a[j]%i]){
find=0;break;
}
mark[a[j]%i]=1;
}
if(find) break;
}
printf("%d\n",i);
}return 0;
}


举报

相关推荐

0 条评论